AdelkaTiVi
25.07.2020 17:06

класс.
Составить программы в тетради, проверить их работу в Паскаль
1. Запишите программу определения принадлежности точки Х отрезку [А; В] .
2. Составьте алгоритм возведения чётного числа в квадрат, а нечётного - в куб.
3. Имеются данные о количестве полных лет трёх призёров спартакиады. Напишите программу, выбирающую и выводящую возраст самого младшего призёра.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yoongiswag
17.12.2021 16:16

Public Class Form1
    Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
        Randomize()
        TextBox1.Text = ""
        Dim n As Integer = 10
        Dim array(n) As Integer
        Dim summa, number As Integer
        Dim i As Integer
        summa = 0
        number = 0
        For i = 1 To n Step 1
            array(i) = Int((100 * Rnd()) + 1)
            TextBox1.Text = TextBox1.Text & array(i) & "  "
            If array(i) Mod 2 = 0 Then
                summa = summa + array(i)
                number = number + 1
            End If
        Next i
        Label1.Text = "Сумма всех положитеьных чисел равна " & summa & ". И количество их равно " & number
    End Sub
End Class

0,0(0 оценок)
Ответ:
Миша20072007
28.02.2020 15:30

program raf105;

const

 n = 10;

var

 a,b,c: array[1..n] of integer;

 i,j,x,max,mpos,b1,c1: integer;

begin

write('Введите максимальное число: ');

readln(x);

writeln('Заполните массив из ',n,' элементов');

for i:=1 to n do

begin

 readln(a[i]);

 if a[i] > x

   then begin

     b1:= b1+1;

     b[b1]:= a[i];

   end

   else begin

     c1:= c1+1;

     c[c1]:= a[i];

   end;

end;

for i:=1 to c1 do

begin

 max:= -10000;

 for j:=i to c1 do

   if c[j] >= max

     then begin

       max:= c[j];

       mpos:= j;

     end;

 c[mpos]:= c[i];

 c[i]:= max;

end;

for i:=1 to b1 do

 a[i]:= b[i];

for i:=1 to c1 do

 a[i+b1]:= c[i];

write('Отсортированный массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

PascalABC 3.4.2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота