kokosik23
18.05.2022 10:31

Написать программу для вычисления y для заданного x по формуле

y= x^3-3,5x^2+2. (Знак - ^ - возведение в степень). Протестировать программу при x=0; x=1; x=13,8; x=-0,5; x=100,35. pascal ABC

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alexey2030
12.01.2022 07:02
USES CRT,Graph;VAR Device,Mode:Integer;    i,x,y,s:Integer;BEGINCLRSCR;       Device:=0;       InitGraph(Device,Mode,'');       s:=100;       x:=320;       y:=240;       for i:=1 to 9 do           begin               SetLineStyle(0,0,ThickWidth);               Circle(x,y,s);               Delay(200);               SetColor(Black);               Circle(x,y,s);               s:=s-10;               SetColor(White);           end;            for i:=1 to 9 do           begin               SetLineStyle(0,0,ThickWidth);               Circle(x,y,s);               Delay(200);               SetColor(Black);               Circle(x,y,s);               s:=s+10;               SetColor(White);           end;          Circle(x,y,s);Readln;END.
0,0(0 оценок)
Ответ:
Comalia
18.05.2021 09:07
#include <iostream>

using namespace std;

int main() {
    int n;
    cout << "Ââåäèòå êîëè÷åñòîâ äîìîâ: ";
    cin >> n;
    cout << endl;
    cout << "Ââåäèòå êîëè÷åñòâî æèòåëåé â êàæäîì  äîìå: ";
    int chet = 0, nechet = 0;
    for (int i = 0; i < n; i++)
    {
        int x;
        cin >> x;
        if (i % 2 == 0)
           chet += x;
        else
            nechet += x;
    }
    cout << endl;
    if (chet == nechet)
       cout << "Ðàâíîå êîëè÷åñòâî æèòåëåé íà îáåèõ ñòîðîíàõ óëèöû." << endl;
    else
        if (chet > nechet)
           cout << "Áîëüøå æèòåëåé íà ÷åòíîé ñòîðîíå óëèöû." << endl;
        else
            cout << "Áîëüøå æèòåëåé íà íå÷åòíîé ñòîðîíå óëèöû." << endl;
    system("pause");
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота