Vsevolod20141
06.05.2023 01:35

Питон. Напишите программу которая заменяет в символьной строке все точки на нули и все буквы х на единицы. Например, из строки '..XX..X.' должна получиться строка '00110010’.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ооггод
06.11.2022 06:18
//Pascal ABC.NET v3.0 сборка 1111

Var 
 ars:array[1..50] of string;
 ark:array[1..50] of integer;
 s:string;
 i,n,k,j:integer;
begin
 readln(n);
 k:=0;
 for i:=1 to n do
  begin;
   readln(ars[i]);
    for j:=1 to 4 do
     delete(ars[i],1,pos(' ',ars[i]));
    s:=ars[i];
    if (s[1]='6') or (s[1]='7') or (s[1]='8') then
     begin;
      inc(k);
      ark[k]:=i;
     end;
  end;
writeln(k);
for i:=1 to k do
writeln(ark[i]);
end.

Пример ввода:
2
Петров Петр Петрович 10 6 2007
Иванов Иван Иванович 10 2 2007
Пример вывода:
1
1
0,0(0 оценок)
Ответ:
Знайка50000000
19.04.2020 07:54
//PascalABC.NET 3.0
const  n = 5;
begin
  var a := ArrRandomReal(n);
  var b := ArrRandomReal(n);
  write('Длины первого катета: ');
  foreach var i in a do write(i : 5 : 2);
  write(NewLine, 'Длины второго катета: ');
  foreach var i in b do write(i : 5 : 2);
  var imax := 0;  for var i := 1 to n - 1 do
    if a[imax] * b[imax] < a[i] * b[i] then
      imax := i;
  writeln(NewLine, 'Номер: ', imax + 1);
  writeln('Катеты: ', a[imax] : 0 : 2, ' ', b[imax] : 0 : 2);
  writeln('Площадь: ', a[imax] * b[imax] / 2 : 0 : 2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота