murzyeva1970
21.12.2021 02:08

Напишите программу для сложения и вычитания двух чисел и введеных с клавиатуры балов дам​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
daurmukhtar99
05.12.2020 03:17
Более красивый вариант) 

Program N_1;                         //Название программы
Var a,b,c:integer;                   //Переменные
BEGIN
Writeln('Введите длину и ширину прямоугольника');  //Вывести данную строку
readln(a,b);                         //Считать a и b
if a<b                                 //Если a<b
then begin                          //то найти периметр
c:=(a+b)*2;
Writeln('Пириметр= ',c)       //и вывести его
end
else begin                         //Если a>b
c:=a*b;                             //то найти площадь
writeln('Площадь= ',c)       //и вывести ее.
end;
END.
0,0(0 оценок)
Ответ:
adelina2001levchuk
05.12.2020 03:17

Из курса математики мы знаем что периметр треугольника равен сумме его трех сторон, в равностороннем треугольнике они равны , потому

P=3*a, где а - сторона равностороннего треугольника.

а площадь расчитывается по формуле

S= \frac{a^{2}\sqrt{3} }{4}

Смотрим программы.

1 Программа подходит, формулы в функциях вроде правильно написаны.

2 Программа не подходит, по виду вроде для квадрата формулы

3 Программа не подходит. Формула площади вроде для треугольника( половина основания на высоту), но не для равностороннего  и в функции для периметра в аргументах 3 штуки - очевидно это стороны треугольника и предполагается что они разные.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота