mishkaievlev
13.04.2020 06:19

Составить программу на языке Составить программу нахождения минимального элемента и его номера в массиве вещественных чисел не более 40, задаваемых вводом с клавиатуры.
2. Сформировать массив (вывести на экран) из т случайных целых чисел на промежутке от -60 до 60, найти сумму чисел больших 20.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katenkafialkaowy2yf
04.05.2020 10:10

program z1;

const n=8;

var a:array [1..n] of integer;

i,m: integer;

begin

writeln ('Результаты заплыва: ');

for i:= 1 to n do

begin

write(i,'-й: ');

readln(a[i])

end;

writeln;

m:=a[i];

for i:= 1 to n do

if a[i]<m then m:=a[i];

writeln('Лучший: ',m)

end.

program z2;

const n=12;

var a:array [1..n] of integer;

i,m: integer;

begin

writeln ('Массив: ');

for i:= 1 to n do

begin

write(i,'-й элемент: ');

readln(a[i])

end;

writeln;

m:=a[i];

for i:= 1 to n do

if a[i]>m then m:=a[i];

writeln('Максимальный: ',m)

end.

Объяснение:

Сначала вводим элементы массива.

Затем предполагаем, что первый элемент наименьший (1 задача) или наибольший (2 задача). Потом сравниваем элементы массива с переменной, в которую записали первый элемент, и меняем переменную, если условие срабатывает. Выводим результат на экран.

0,0(0 оценок)
Ответ:
see99aa
13.07.2021 02:40

Я буду писать часть предложения, а внизу табличку, чтобы понятнее было))

Набрать 9 литров в первую ёмкость.

1. 9 л      2. 0л (пока что) 

Перелить 5 литров во вторую ёмкость.

1.4 л       2. 5л

Из второй ёмкости вылить всю воду

1.4л        2. 0л

И из первой ёмкости перелить во вторую ёмкость оставшиеся 4 литра.

1.0 л      2. 4л

Набрать полную первую ёмкость

1. 9л     2. 4л

И из неё перелить во вторую 1 литр.

1. 8л     2. 5л

Воду из второй емкости вылить

1.8 л     2. 0л

И из 8 литров воды в первой ёмкости перелить во вторую ёмкость 5 литров

1. 3л     2. 5л

Вот и все!!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота