nikitakurganov
11.04.2021 19:53

Составьте программу, выясняющую, есть ли в двухмерном массиве А(N,M) столбцы, в которых все элементы различны.

Нужно, чтобы программа запустилась в PascalABC

Очень

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Денок07
05.11.2020 20:19
Uses Crt;
const
  n=10;
var
  a,b:array[1..n] of integer;
  i,k,t:integer;
begin
  ClrScr;
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(50);
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    b[i]:=Random(50);
    Write(b[i],' ')
    end;
  Writeln;
  Write('k t='); Read(k,t);
  for i:=1 to n do begin
    if a[i]>t then a[i]:=a[i]+4;
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    if b[i]>10*k then b[i]:=b[i]+k;
    Write(b[i],' ')
    end;
  Readkey
end.

Тестовое решение:
1 6 23 12 47 1 44 24 6 18
31 30 30 29 0 3 43 32 46 21
k t=2 20
1 6 27 12 51 1 48 28 6 18
33 32 32 31 0 3 45 34 48 23
0,0(0 оценок)
Ответ:
mrazamar0kk
05.11.2020 20:19
var  mas1, mas2: array[0..9] of integer;  t, k, i, j: integer; 
begin  
readln(t);  
readln(k);  
for j := 0 to 1 do  begin   
      if (j = 1) then writeln();        
                 for i := 0 to 9 do    begin      
                          if(j = 0) then begin       
                                  mas1[i] := random(100);        
                                    write(mas1[i], ' ');       
                                    if mas1[i] > t Then mas1[i] := mas1[i] + 4;      
                              end      
                            else 
                               begin       
                                      mas2[i] := random(100);        
                                      write(mas2[i], ' ');       
                                       if mas2[i] > 10 * K Then         
                                            mas2[i] := mas2[i] + K;      
                                end;    
                       end;       
                  for i := 0 to 9 do     
                         if (j = 0) then 
                               write(mas1[i]) 
                        else 
                                write(mas2[i]);    
               writeln();  
           end;  
readln();
end.

))
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота