ksysharaz
17.04.2022 15:43

Составьте программу нахождения наибольшего по модулю элемента целочисленного массива A(M,M), кратного 11. (ПАСКАЛЬ!)

Нужно, чтобы программа запустилась в PascalABC.net

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aliyaulanova1
15.01.2020 00:04
// PascalABC.NET 3.0, сборка 1128

procedure MatInput(M:array[,] of integer);
begin
  var nr:=Length(M,0);
  var nc:=Length(M,1);
  WritelnFormat('Введите построчно массив размером {0}x{1}',nr,nc);
  for var i:=0 to nr-1 do
    for var j:=0 to nc-1 do
      Read(M[i,j]);
end;

function S(M:array[,] of integer):integer;
begin
  Result:=0;
  var Zero:integer;
  for var i:=0 to Length(M,0)-1 do begin
    Zero:=1; 
    for var j:=0 to Length(M,1)-1 do
      if M[i,j]=0 then begin Zero:=0; Break end;
    Result+=Zero;
    if Result=1 then begin Result:=0; Exit end
    end;
  Result:=1
end;

begin
  var A:=new integer[3,4]; MatInput(A);
  var B:=new integer[3,3]; MatInput(B);
  Writeln(S(A));
  Writeln(S(B));
end.

Тестовое решение:
Введите построчно массив размером 3x4
1 2 3 4
5 6 7 8
9 0 1 2
Введите построчно массив размером 3x3
1 2 0
2 0 1
0 1 0
0
1
0,0(0 оценок)
Ответ:
MalenkayaStervochka
15.01.2020 00:04
// PascalABC.NET 3.0, сборка 1128

procedure MatInput(M:array[,] of integer);
begin
  var nr:=Length(M,0);
  var nc:=Length(M,1);
  WritelnFormat('Введите построчно массив размером {0}x{1}',nr,nc);
  for var i:=0 to nr-1 do
    for var j:=0 to nc-1 do
      Read(M[i,j]);
end;

function S(M:array[,] of integer):integer;
begin
  Result:=0;
  var Zero:integer;
  for var i:=0 to Length(M,0)-1 do begin
    Zero:=1; 
    for var j:=0 to Length(M,1)-1 do
      if M[i,j]=0 then begin Zero:=0; Break end;
    Result+=Zero;
    if Result=1 then begin Result:=0; Exit end
    end;
  Result:=1
end;

begin
  var A:=new integer[3,4]; MatInput(A);
  var B:=new integer[3,3]; MatInput(B);
  Writeln(S(A));
  Writeln(S(B));
end.

Тестовое решение:
Введите построчно массив размером 3x4
1 2 3 4
5 6 7 8
9 0 1 2
Введите построчно массив размером 3x3
1 2 0
2 0 1
0 1 0
0
1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота