daffidovа
30.08.2022 08:35

Написать программу вычисления значения по формуле мощности,силы тока и напряжения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
GiftOfDeath
26.09.2021 17:58
1)
const n=10;
var a:array[1..n] of integer;
i,min,s:integer;
begin
for i:=1 to n do
begin
a[i]:=random(81)+10;
write(a[i]:4);
end;
writeln;
min:=a[1];
for i:=1 to n do
begin
if a[i]<min then min:=a[i];
s:=s+a[i];
end;
writeln('min = ',min);
writeln('s = ',s);
end.

Пример:
 54 58 67 78 58 79 54 78 44 60
min = 44
s = 630

2)
const n=9; m=6;
var a:array[1..n,1..m] of integer;
i,j:integer;
begin
for i:=1 to n do
for j:=1 to m do a[i,j]:=i;
for i:=1 to n do
begin
for j:=1 to m do write(a[i,j]);
writeln;
end;
end.

Результат: 
111111
222222
333333
444444
555555
666666
777777
888888
999999 
0,0(0 оценок)
Ответ:
FarLime
20.05.2023 21:38
#include <iostream>
#include <iomanip>
#include <ctime>

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    const int N = 5;
    int matrix[N][N];
    int A[(N*N) / 2], B[(N*N)/2];
    int k = 0;
    srand(time(NULL));
    for (int i = 0; i < N; i++)
    {
        std::cout << std::endl;
        for (int j = 0; j < N; j++)
        {
            matrix[i][j] = rand() % 100;
            std::cout << std::setw(3) <<  matrix[i][j] << " ";
        }
    }
    for (int i = 0; i < N; i++)
        for (int j = 0; j < N; j++)
            if (i >= j)
            {
                A[k] = matrix[i][j];
                k++;
            }
    std::cout << std::endl;
    std::cout << "Массив, содержащий элементы, лежащие на главной диагонали и ниже ее:" << std::endl;
    for (int i = 0; i < k; i++)
        std::cout << A[i] << " ";
    k = 0;
    std::cout << std::endl;
    for(int i=0; i<N; i++)
        for (int j = N - i-1; j < N; j++)
        {
            B[k] = matrix[i][j];
            k++;
        }
    std::cout << "Массив, содержащий элементы, лежащие на побочной диагонали и ниже ее:" << std::endl;
    for (int i = 0; i < k; i++)
        std::cout << B[i] << " ";
    std::cout << std::endl;
    system("pause");
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота