злата197
17.01.2023 07:53

написать программу на С++. Условия на 1 картинке. Пример на

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Женечка5551
24.11.2021 04:59

program raf105;

var  

 white,blue,red,x,y,z: integer;

 w,b,r: boolean;

begin

writeln('Ввод:');

readln(white, blue, red, x, y, z);

repeat

 w:= false;

 b:= false;

 r:= false;

 if white >= x

   then begin

     white-= x;

     blue+= 1;

   end

   else w:= true;

 if blue >= y

   then begin

     blue-= y;

     red+= 1;

   end

   else b:= true;

 if red >= z

   then begin

     red-= z;

     white+= 1;

   end

   else r:= true;

until w and b and r;

writeln('Вывод:');

writeln(white,' ', blue,' ', red);

end.

PascalABC 3.4.2
0,0(0 оценок)
Ответ:
riga04
18.12.2021 19:11
#!/usr/bin/env python
# coding: utf-8
"""Определение типа треугольника по сторонам.
Python 2.X.
"""

msg = 'Введите стороны треугольника: '
input = raw_input(msg).split()

try:
    a, b, c = [float(i) for i in input]
except ValueError:
    print('Введены не числовые значения! Выход...')
    quit()

if (a >= b + c or
    b >= a + c or
    c >= a + b):
    print('Не', end=' ')
elif a ** 2 + b ** 2 == c ** 2:
    print('Прямоугольный', end=' ')
elif (a ** 2 + b ** 2 > c ** 2 and
      a ** 2 + c ** 2 > b ** 2 and
      c ** 2 + b ** 2 > a ** 2):
    print('Остроугольный', end=' ')
else:
    print('Тупоугольный', end=' ')
print('треугольник')
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота