doktornastia03
16.04.2021 16:06

Питон:В одном из своих видео Маша рассказывает о том, как она провела N дней в Петербурге и о том, сколько денег она тратила на развлечения в каждый из этих дней.

Найдите, на какой по счёту день поездки Маша потратила больше всего денег.

Если дней, когда Маша потратила наибольшую сумму денег, несколько, то выведите номер первого из них.

Формат входных данных
Целое положительное число 1 < N < 1000 - количество дней

N целых положительных чисел < 1000000 - траты в каждый из дней по порядку

Формат выходных данных
Номер дня.

входные данные выходные данные
5
150
120
160
170
270
5
4
100
200
300
300

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sofiya130308
12.10.2020 14:47

r=0

m=0

x=0

N=int(input())

for i in range(N):

   x=int(input())

   if x>m:

       r=i+1

       m=x

print(r)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота