vitakotov009
31.10.2021 07:15

НАПИСАТЬ НА ПИТОНЕ
Дан список из чисел и индекс элемента в списке k. Удалите из списка элемент с индексом k, сдвинув влево все элементы, стоящие правее элемента с индексом k.
Программа получает на вход список, затем число k. Программа сдвигает все элементы, а после этого удаляет последний элемент списка при метода pop().
Программа должна осуществлять сдвиг непосредственно в списке, а не делать это при выводе элементов. Также нельзя использовать дополнительный список.
Входные данные: Вводится список чисел. Все числа списка находятся на одной строке. В следующей строке вводится одно целое число. Все числа целые и не превосходят 100.
Выходные данные: Выведите ответ на задачу.
Примеры:
Ввод:
1 2
1
Вывод:
1

Ввод:
1 2
0
Вывод:
2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
холера678
03.09.2020 19:21

Ну в принципе вот, print последний сделай таким, какой нужен

a=input().split()

k=int(input())

for i in range(k,len(a)-1):

   a[i]=a[i+1]

a.pop(len(a)-1)

for i in range(len(a)):

   print(a[i],end=' ')

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота