Luciferiy
11.07.2021 11:06

Написать программу в Pascal, которая инвертирует нечетные числа в целом неотрицательном числе.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ArtemPatsaliuk
10.05.2020 08:32

#include <iostream>

using namespace std;

int main()

{

   int number, last_number;

   int quantity = 0;

   cin >> number;

   while (number > 0)

   {

       last_number = number % 10;

       if (last_number == 3)

       {

           quantity++;

       }

       number /= 10;

   }

   cout << quantity;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int number, last_number;  // Создание целочисленных переменных:

number - число, вводимое с клавиатуры;last_number - последняя цифра числа для проверки на равенство.

   int quantity = 0;  // Создание целочисленной переменной, хранящей в себе количество цифр "3" в числе.

   cin >> number;  // Ввод числа с клавиатуры

   while (number > 0)  // Пока значение переменной number > 0

   {

       last_number = number % 10;  // Отделяем от числа последнюю цифру путем выяснения остатка от деления на 10 и присваиваем это значение в переменную last_number

       if (last_number == 3)  // Если значение переменной last_number = 3

       {

           quantity++;  // К переменной quantity прибавляем единицу

       }

       number /= 10;  // Отделяем последнюю цифру от числа путем целочисленного деления на 10

   }

   cout << quantity;  // Вывод ответа

}

0,0(0 оценок)
Ответ:
Gjjsg
16.12.2020 19:15
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота