tanaletinaaaaa
03.12.2020 18:45

Составить программу, которая сортирует четыре числа по порядку возрастания и убыванию. Несколько вариантов Через if... Then
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sc8054456p08m25
12.10.2020 11:52

вот программа сортирующая n чисел  

uses crt;  

const nmax=100;  

var a:array[1..nmax] of real;  

n,i,j:integer;  

x:real;  

begin  

clrscr;  

randomize;  

repeat  

write('n=');  

readln(n);  

until n in [1..nmax];  

writeln('Исходный массив: ');  

for i:=1 to n do  

begin  

a:=10*random;  

write(a:5:2);  

end;  

writeln;  

for i:=1 to n-1 do  

for j:=i+1 to n do  

if a<a[j]>;  

a:=a[j];  

a[j]:=x;  

end;  

writeln('Сортировка: ');  

for i:=1 to n do  

write(a:5:2);  

readln  

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота