zulya1072
16.08.2022 00:46

Задача :
Пусть генератор случайных чисел заполнит массив из 10 вещественных чисел. Каждое число, помещаемое в массив, должно быть из диапазона значений от 0 до 20.
Внимание: 10- это размер массива, который определяется при описании и влияет на циклы.
0-20 –это диапазон значений, который определяется только в формуле.

Задание:
1) Выполните программу и запишите протокол.
2) Измените программу так, чтобы массивы поменял имя (c) и тип на целый
3) Измените программу так, чтобы в массиве уменьшилось количество элементов до 15.
4) Измените программу так, чтобы значение элементов определялось из диапазона [-10,10]
5) Измените программу так, чтобы готовый массив выводился в отдельной строке;
6) Найдите количество положительных элементов массива. Для этого:
− опишите переменную для накопления суммы (Kol);
− задайте ей начальное значение, равное 0 (до цикла);
− после определения значения элемента, введите условную структуру для проверки
если c[i]>0 то Kol:=Kol+1;
− после вывода массива , произведите вывод результата.
Обрати внимание на примерный протокол для выполнения результата

Нажмите на рекламу ниже и сразу увидите ответ
Ответ:
topciknazaraakinceva
20.09.2022 00:27
Специально для вас выловил ошибки, находящиеся в предыдущем решении. Кому-то не повезло :(

//PascalABC
var
    S : array[1..10000] of integer;
    A, B, C, i, N, min : integer;
    W : real;
begin
    write('Укажите размер массива > ');
    readln(N);
    write('Вводите элементы массива > ');
    for i := 1 to N do
        readln(S[i]);
       
    A := 0;
    min := S[1];
    C := 0;
    for i := 1 to N do begin
        if S[i] > 0 then A := A + S[i];
        if S[i] < min then begin
            B := i;
            min := S[i];
        end;
        if S[i] mod 5 = 0 then C := C + 1;
    end;
    W := B + A / (C + 1);
    writeln('Сумма элементов ', A);
    writeln('Номер минимального эл-та ', B);
    writeln('Количество кратных пяти ', C);
    writeln('Параметр W ', W);
end.
0,0(0 оценок)
Ответ:
longassride
20.09.2022 00:27
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  var n:=ReadInteger('Количество элементов массива ');
  var m:=ArrRandom(n,-50,50); m.Println(', ');
  var a:=0; var b:=0; var c:=0;
  for var i:=0 to n-1 do begin
    if m[i]>0 then a:=a+m[i];
    if m[i]<m[b] then b:=i;
    if m[i] mod 5 = 0 then Inc(c)
  end;
  var w:=(b+1)+a/(c+1);
  WritelnFormat('A={0}, B={1}, C={2}, W={3}',a,b+1,c,w);
  Writeln('Принято, что элементы массива нумеруются от единицы')
end.

Тестовое решение:
Количество элементов массива  13
-43, -15, 18, -8, -13, -47, -36, 6, -16, 45, 33, 33, -24
A=135, B=6, C=2, W=51
Принято, что элементы массива нумеруются от единицы

Составить программу вычисления, w = b + a - сумма положительных элементов массива; b – номер наимень
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота