Linaa631
29.05.2022 19:28

На базе программы Скретч https://scratch.mit.edu/projects/editor/?tutorial=home от МИТ Массачусетский технологический институт решить такую задачу
у нас есть пешка .Она должна ходить строго по клеточкам .когда спрайт нажат , подсвечивает ходы куда можно ходить ходим.Фигура должна находиться строго в центре клеток .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kiss537
23.06.2022 21:35

program calklin;

uses

 crt;

var

 a, b, x: real;

begin

 textcolor(red);

 gotoxy(10, 5);

 write('Вас приветствует калькулятор решать линейные уравнения');

 gotoxy(10, 6);

 write('Введите а=');

 readln(a);

 gotoxy(10, 7);

 write('Введите b=');

 readln(b);

 gotoxy(10, 8);

 if a = 0

 then

 begin

   gotoxy(10, 9);

   textcolor(red);

   writeln('Нет корней')

 end

 else

 begin

   if a <> 0

   then

   begin

     gotoxy(10, 10);

     textcolor(red);

     x := (-b / a);

     writeln('Уравнение имеет корень и он равен: x =', x, '');

   end;

 end;

end.

0,0(0 оценок)
Ответ:
Lopsiwk
10.12.2022 15:14

// operations_array.cpp: определяет точку входа для консольного приложения.

#include "stdafx.h"
#include <iostream>
#include <ctime>
using namespace std;

int main(int argc, char* argv[])
{
srand(time(NULL));
setlocale(LC_ALL, "rus");
int length_array;
cout << "Укажите количество элементов массива: ";
cin >> length_array;

float *arrayPtr = new float [length_array]; // одномерный динамический массив

// заполняем одномерный массив случайными числами
for (int counter = 0; counter < length_array; counter++)
{
arrayPtr[counter] = - 5.00 + ((rand() % 101) / 10.0); // генерируем случайные числа [-5, 5]
cout << arrayPtr[counter] << " "; // вывод сгенерированного числа
}
cout << endl;

float min = arrayPtr[0]; // инициализируем первым элементом массива
int number_min = 0; // номер минимального элемента
for (int counter = 0; counter < length_array; counter++)
{
if (min > arrayPtr[counter])
{
min = arrayPtr[counter]; // минимальный элемент
number_min = counter; // номер минимального элемента
}
}
cout << "номер минимального элемента = " << (number_min + 1) << endl; // номер минимального элемента

double product = 1;
for (int counter = 0; counter < length_array; counter++)
{
if (arrayPtr[counter] < 0) // находим первое отрицательное число
{
counter++; // переключаемся на следующий элемент
while (arrayPtr[counter] > 0) // пока не нашли второе отрицательное число
{
product *= arrayPtr[counter]; // накапливаем произведение элементов
counter++;
}
break; // выход из цикла for
}
}
cout << "произведение = " << product << endl;

float *relocation_arrayPtr = new float [length_array]; // одномерный динамический массив для перестановок
int index = 0; // индекс массива перестановок

// заполняем массив элементами, модуль которых не превышает 1
for (int counter = 0; counter < length_array; counter++)
{
if (abs(arrayPtr[counter]) <= 1)
{
relocation_arrayPtr[index] = arrayPtr[counter];
index++;
}
}

// заполняем массив элементами, модуль которых больше 1
for (int counter = 0; counter < length_array; counter++)
{
if (abs(arrayPtr[counter]) > 1)
{
relocation_arrayPtr[index] = arrayPtr[counter];
index++;
}
}

// напечатать преобразованный массив
cout << "\nПреобразованный массив:\n";
for (int counter = 0; counter < length_array; counter++)
{
cout << relocation_arrayPtr[counter] << " ";
}
cout << endl;

// высвобождение памяти отводимой под одномерный динамический массив:
delete [] arrayPtr;
delete [] relocation_arrayPtr;
system("pause");
return 0;

 

 

 

  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота