jolytalib
23.03.2021 04:00

написать программу для вычисления данного выражения на языке C#

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Глеб0707
31.01.2020 12:19

Бiблiотека random присутня пiсля установки, тому хай вас не лякає її присутнiсть

from random import randint

lst = []

# список з 10-тьма випадковими числами вiд -10 до 10

for i in range(10):

   lst.append(randint(-10, 10))

# тут я застосував технологiю list comprehension

more_then_zero = [a for a in lst if a > 0]

less_then_zero = [a for a in lst if a < 0]

# сумма/кiлькiсть/середнє арифметичне чисел бiльших за 0

print(sum(more_then_zero))

print(len(more_then_zero))

print(sum(more_then_zero) / len(more_then_zero))

print("\n") # банальний вiдступ

# сумма/кiлькiсть/середнє арифметичне чисел менших за 0

print(sum(less_then_zero))

print(len(less_then_zero))

print(sum(less_then_zero) / len(less_then_zero))

0,0(0 оценок)
Ответ:
alinachaiun
01.03.2023 10:18

#include <iostream>

#include <vector>

using namespace std;

int main() {int m, n, cx, cy;

 cin >> m >> n;

 vector<int>a;

 a.reserve(m*n);

 for (int i = 0;i < m;++i) {

   for(int j = 0;j < n;++j) {

     int v;

     cin >> v;

     a.push_back(v);

   }

 }

 int x;

 int value = 0;

 cin >> x;

 for (int k = 0;k < x;++k) {

   cin >> cx >> cy;

   if((a[cy-1 + (cx-1)*cy]) != -100) {

     value += a[cy-1 + (cx-1)*cy];

     a[cy-1 + (cx-1)*cy] = -100;

   }

 }cout << value;

 

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота