thebrianmaps2000
05.02.2022 14:19

Написать программу Паскаль дано целое положительное число напечатать количество и сумму его цифр

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
appleju
12.10.2020 07:19

var

 n, i, count, sum: integer;

begin

 Writeln('Ввидете число: ');

 Read(n);

 count := 0;

 while n <> 0 do

 begin

   i := n mod 10;

   sum += i;

   count += 1;

   n := n div 10;

 end;

 Writeln('Сумма всех цифр: ', sum);

 Writeln('Количество цифр: ', count);

end.

Тестовое решение

Введите число:  

51231

Сумма всех цифр: 12

Количество цифр: 5

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота