djgas10
04.09.2020 06:13

Написать программу , которая определяет наименьшее число из трех неравных чисел с плавающей запятой, с элементов (поле ввода чисел, метки и кнопки)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
PlizHelpMee
29.03.2021 02:25

Переделал программу с паскаля на С++

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

int main(){

srand(time(0));

system("chcp 1251 > nul");

int q,x,y,z,a,b,c,d,e;

double w;

cout << "Введите x: ";

cin >> x;

cout << "Введите y: ";

cin >> y;

cout << "Введите z: ";

cin >> z;

a = x*y*z;

b = 3*z*x;

c = 2*(x+y+z);

d = max(a,b);

e = max(b,c);

q = max(e,d);

cout << "Максимум: " << q<< endl;

w = min((3*x*y*z),(q/2));

cout << "Максимум: " << w << endl;

   return 0;

}

0,0(0 оценок)
Ответ:
илья1968
03.02.2020 17:00

Недостатки: отсутствие возможности создавать реалистичную картинку, близкую по качеству к фотографии, это значительно уменьшает применение векторной графики;

обширная библиотека фильтров, которые создают интереснейшие эффекты при работе с растровыми картинками, в случае работы с кривыми абсолютно бесполезны;

в отличие от растровых изображений, файлы, содержащие картинки в векторе, можно редактировать только в той программе, в которой они были созданы изначально; но из этого правила есть исключения, существуют универсальные форматы, они изменяются в большинстве векторных редакт

Достоинства: Векторная графика представляет собой совокупность математически описанных объектов. Этим обусловлены неограниченные возможности ее масштабирования. При увеличении растрового изображения непременно будет теряться его качество, размер векторных иллюстраций напротив можно свободно изменять, не теряя их визуальных характеристик. Это возможно, благодаря тому, что каждая точка растровой картинки имеет свои координаты, а между точками расположены кривые, внешний вид которых зависит от расположения точек.

Еще одним достоинством векторных изображений является их небольшой вес. Такие файлы можно с легкостью переслать по электронной почте, а с их редактированием справится любой компьютер.

Важным преимуществом векторных картинок является их четкость при широкоформатной печати, что определяет их популярность при создании рекламных баннеров.

Также несомненным достоинством векторной графики является то, что дизайнер имеет возможность работать с отдельными фрагментами изображений. Вы можете перемещать и вращать отдельные линии и области, менять цвет фрагментов картинки, группировать объекты и т.д.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота