dkurmanbek
10.06.2022 07:34

Написать программу, которая считывает две строки, введённых пользователем. После этого программа должна вывести на экран, какая строка длиннее и на сколько символов.(Python)(В коде должно быть ветвление if … elif … else
Вычисление разницы в длине строк должно выполняться в функции, которая принимает две строки и возвращает целое число.)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
joryk2012
12.10.2020 06:42

def get_string_length_diff(string1, string2):

   return len(string1)-len(string2)

fstring = input()

sstring = input()

strings_diff = get_string_length_diff(fstring, sstring)

print(f'первая строка длиннее на {abs(strings_diff)} символов' if (strings_diff > 0) else f'вторая строка длиннее на {abs(strings_diff)} символов')

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота