baget97ozu06u
04.05.2021 17:31

решить информатику

Составить программу, которая запрашивает число, и если оно оказывается больше 23 печатает сумму этого числа и 8, иначе печатает "число меньше

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ася992
06.06.2020 05:38
Var
День,Месяц:byte;
Begin
Write('№ дня = ');ReadLn(День);
Var C:=365-День;
Write('№ месяца = ');ReadLn(Месяц);
Case Месяц of
2:C:=C-31;
3:C:=C-59;
4:C:=C-90;
5:C:=C-120;
6:C:=C-151;
7:C:=C-181;
8:C:=C-212;
9:C:=C-243;
10:C:=C-273;
11:C:=C-304;
12:C:=C-334
End;
if (C mod 100>10)and(C mod 100<20) then Write('До нового года осталось ',C,' дней')
else
Case C mod 10 of
1:Write('До нового года остался ',C,' день');
2..4:Write('До нового года осталось ',C,' дня');
0,5..9:Write('До нового года осталось ',C,' дней')
End
End.
0,0(0 оценок)
Ответ:
ibondarenk2013
21.05.2023 20:14
Код в Turbo Pascal:
USES Graph,CRT;
VAR x,y,dx,dy,Device,Mode,i: Integer; 
BEGIN 
   Device:=0; 
   InitGraph(Device,Mode,''); 
   x:=10; y:=10; 
   dx:=1; dy:=1; 
   i:=1; 
Repeat     
   SetColor(Cyan);     
   Circle(x,y,10);     
   SetFillStyle(1,3);     
   FloodFill(x,y,Cyan);     
   Delay(10);     
   SetColor(Black);     
   Circle(x,y,10);     
   SetFillStyle(1,0);     
   FloodFill(x,y,Black);     
   x:=x+dx; y:=y+dy;     
if (x>300) OR (y>200) then                           
                                   begin                           
                                      x:=10;                           
                                      y:=10;                           
                                      i:=i+1;                           
                                   end;

  until i>5;
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота