LianaTesten200615
01.02.2022 15:18

Напишите программу, которая вычисляет сумму n-первых целых положительных чисел
S = 1 + 2 + 3 + ... + n
Количество суммируемых чисел n должно вводиться пользователем во время работы программы

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Darina6940
17.10.2021 17:53

Даны два ненулевых числа. Найти их сумму, разность, произведение и частное

1. Даны два ненулевых числа. Найти их сумму, разность, произведение и частное.

Даны два действительных числа x и y. Вычислить их сумму, разность, произведение и частное

а)F=x^2(x^2+1) б)Даны два действительных числа x и y. Вычислить их сумму, разность, произведение и...

Даны два ненулевых числа. Найти их сумму, разность, произвеение и частное

даны два ненулевых числа.найти их сумму,разность,произвеение и частное.

Даны два действительных числа А и В. Получить их сумму, разность и произведение

Даны два действительных числа А и В. Получить их сумму, разность и произведение

5

Объяснение:

0,0(0 оценок)
Ответ:
Кристина1718
11.05.2023 12:43
1)

const
  n=40;
var
  a:array [1..n] of integer;
  i,k:integer;
begin
  Randomize;
  k:=0;
  Writeln('Исходный массив');
  for i:=1 to n do begin a[i]:=random(63)+20; Write(a[i],' ') end;
  Writeln; Writeln('Четные элементы, кратные 3');
  for i:=1 to n do
    if a[i] mod 6=0 then begin Inc(k); Write(a[i],' ') end;
  Writeln; Writeln('Отобрано элементов: ',k)
end.

Пример
Исходный массив
43 49 27 45 57 20 54 22 74 79 57 64 30 41 67 58 36 68 79 46 28 74 61 21 80 57 50 24 80 36 27 57 38 38 41 71 50 69 39 48
Четные элементы, кратные 3
54 30 36 24 36 48
Отобрано элементов: 6

2)

const
  n=20;
var
  a:array [1..n] of integer;
  i,imin:integer;
begin
  Randomize;
  Writeln('Исходный массив');
  imin:=1;
  for i:=1 to n do begin
    a[i]:=random(351)+20;
    Write(a[i],' ');
    if a[i]<a[imin] then imin:=i
    end;
  Writeln;
  Writeln('Минимальный элемент a[',imin,']=',a[imin])
end.

Пример
Исходный массив
292 54 248 310 181 210 263 284 255 156 177 340 173 39 108 144 270 40 318 155
Минимальный элемент a[14]=39
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота