Kotja6996
21.01.2022 12:17

1. Составить программу, которая будет считывать введённое пятизначное число (Установить проверку на количество введенных символов). После чего, каждую цифру этого числа необходимо вывести в новой строке. {ответ предоставить в виде листинга – main.cpp}

2. Определить класс Product, который содержит такие поля (члены класса): закрытые – наименование продукта, артикул и количество , публичные – методы ввода данных и отображения их на экран. Объявить два объекта класса, внести данные и показать их. {ответ предоставить в виде листинга – main.cpp}

С++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
1FACE1
09.01.2024 09:41
Вот пример кода для выполнения обоих заданий:

1. Первая программа, которая считывает и выводит каждую цифру в новой строке:

```cpp
#include
#include

int main() {
std::string input;

// Вводим число и проверяем его длину
do {
std::cout << "Введите пятизначное число: ";
std::cin >> input;
} while (input.length() != 5);

// Выводим каждую цифру в новой строке
for (int i = 0; i < 5; i++) {
std::cout << input[i] << std::endl;
}

return 0;
}
```

Обоснование:

- Мы используем строку (`std::string`), чтобы считать число пользователя, так как это позволяет нам проверить количество символов введенного числа.
- В цикле `do-while` мы продолжаем запрашивать число, пока пользователь не введет пятизначное число (`input.length() != 5`).
- Затем мы используем цикл `for` для прохода по каждой цифре введенного числа и выводим их по одной в новой строке.

2. Определение класса `Product` с закрытыми полями и публичными методами:

```cpp
#include
#include

class Product {
private:
std::string name;
std::string article;
int quantity;

public:
void input() {
std::cout << "Введите наименование продукта: ";
std::cin >> name;

std::cout << "Введите артикул продукта: ";
std::cin >> article;

std::cout << "Введите количество продукта: ";
std::cin >> quantity;
}

void display() {
std::cout << "Наименование продукта: " << name << std::endl;
std::cout << "Артикул продукта: " << article << std::endl;
std::cout << "Количество продукта: " << quantity << std::endl;
}
};

int main() {
Product product1;
Product product2;

product1.input(); // Вводим данные для первого продукта
product2.input(); // Вводим данные для второго продукта

product1.display(); // Выводим данные первого продукта
product2.display(); // Выводим данные второго продукта

return 0;
}
```

Обоснование:

- Мы создаем класс `Product` с приватными полями `name`, `article` и `quantity`, чтобы хранить информацию о продукте.
- В классе также есть два публичных метода: `input()` и `display()`.
- Метод `input()` запрашивает у пользователя наименование продукта, артикул и количество и сохраняет их в соответствующих полях.
- Метод `display()` выводит на экран информацию о продукте, используя значения полей.
- В функции `main()` мы создаем два объекта типа `Product`, вводим данные для каждого из них с помощью метода `input()`, а затем выводим эти данные с помощью метода `display()`.

Надеюсь, это поможет вам понять и выполнить эти задания!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота