karina36517
06.02.2021 09:45

нужно составить программу в паскале
Заранее Задание:
Найдите среднее арифметическое элементов массива, заполненного случайными числами от 6 до 21. Размерность массива вводится с клавиатуры. Вывести на экран все элементы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kiskammp014dd
12.10.2020 01:34

PascalABC.Net

Varian 1:

begin  var n := ReadInteger('Введите размер массива');  var a := ArrRandom(n, 6, 21);  Print(a, 'Srednee: ', a.Average); end.

Varian 2:

var  f: array[1..100] of integer;  i, sum, N: integer;  srednee: real; begin  Writeln('Введите размер массива: ');  Read(N);  sum := 0;  randomize;  for i := 1 to N do  begin    f[i] := random(6, 21);    write(f[i], ' ');    sum := sum + f[i];  end;  srednee := sum / n;  writeln('Srednee: ', srednee:3:3); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота