Turtle183119
29.11.2022 03:59

Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляет А^N без использования операции возведения в степень.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Sniper2016
12.10.2020 01:32

a = int(input())

n = int(input())

a1 = a

for k in range (n - 1) :

   a *= a1

print (a)

Объяснение:

Мы вводим два числа и начинаем цикл While, в котором мы каждый раз когда делаем возведение в степень (умножаем число А на самого себя) уменьшаем число N (значащее степень, в которую надо возвести число)

Прикладываю базовые тесты:


Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляе
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота