Mariyana10
10.12.2020 15:12

(НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON) Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2. (НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
крис897
11.10.2020 23:17

summ = 0

a = int(input())

while a != 0:

   if a % 7 == 0 and a % 10 == 2:

       summ += a

   a = int(input())

print(summ)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота