sofyadeeva
04.11.2021 21:30

написать программу на с++ содержащую функцию нахождения наибольшего числа из N введенных

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lenab85
21.04.2020 07:31
Program z1;
        var a:array[1..100] of integer;
        n,i:byte;ma:integer;
begin
        write('n=');readln(n);
        for i:=1 to n do begin
                write(i,')');readln(a[i])
        end;
        ma:=a[1];
        for i:=1 to n do begin
                if a[i]>ma then begin
                        ma:=a[i]
                end
        end;
        for i:=1 to n do begin
                a[i]:=ma
        end;
        writeln('test n=',n);
        for i:=1 to n do begin
                writeln(a[i])
        end;
        readln
end.
0,0(0 оценок)
Ответ:
evzrezovatatya
03.01.2023 02:12
1. Вероятность вынуть первым красный карандаш определяется отношением количества красных карандашей к их общему числу, т.е. 2/4 или 1/2.
2. Теперь в коробке остался один красный карандаш, а всего карандашей - три. Вероятность вынуть красный карандаш равна 1/3.
3. Вероятность наступления обоих событий определяется произведением обоих вероятностей и составляет 1/2 × 1/3 = 1/6
Итак, два красных (а также два синих) карандаша можно вынуть с вероятностью 1/6.
Сумма всех вероятностей равна 1, с вероятностью 1/6 оба карандаша будут красные, 1/6 - синие, значит на долю события, когда карандаши будут разного цвета остается 1 - 1/6 - 1/6 = 2/3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота