вопросик70
22.07.2021 15:17

Задачи на циклы while . Напишите программу, которая получает на вход положительное число. Если введенное число четное выводятся все четные числа до этого числа, если нечетное выводятся все нечетные числа до этого числа.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vovacool27
11.10.2020 23:12

var

 n: integer;

 i: integer;

begin

 i := 0;

 writeln('Введите число: ');

 readln(n);

 if n mod 2 = 0 then

   while i < n do

   begin

     i := i + 1;

     if i mod 2 = 0 then

       write(i, ' ')

   end

 else

   while i < n do

   begin

     i := i + 1;

     if i mod 2 <> 0 then

       Write(i, ' ')

   end

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота