Xom9l4ok
28.01.2023 05:29

А1. Программа – это:

А) алгоритм, в котором команды выполняются последовательно одна за другой;

Б) алгоритм, записанный с использованием блок-схем;

В) алгоритм, записанный с какого-либо языка программирования;

Г) процесс решения задачи, разбитый на определённое число шагов.

А2. Укажите верное обозначение массива.

А) Х[1.5] Б) N[2,4] В) i[2..3] Г) Z[6…12]

А3. Как производятся все действия над одномерными массивами?

А) через оператор READ; Б) через «обнуление»;

В) через оператор RANDOMIZE; Г) в цикле.

А4. В программе описан одномерный целочисленный массив с индексами от 1 до 5. В приведённом ниже фрагменте программы массив сначала заполняется, а потом изменяется. Чему будут равны элементы этого массива?

for i:=1 to 5 do

A[i]:=2*i+1;

for i:=5 downto 1 do

A[i]:= A[6-i];

end;

А) 3 5 7 9 11; Б) 11 9 7 5 3; В) 11 9 7 9 11; Г) 3 5 7 5 3.

А5. Алгоритм, целиком используемый в составе другого алгоритма, называется:

А) рекурсивным;

Б) вс В) основным;

Г) дополнительным.

А6. Подпрограмма, имеющая произвольное количество входных и выходных данных, называется:

А )процедура; Б) функция; В) массив; Г) рекурсия.

В заданиях группы Б приведите полное решение задачи или дайте развёрнутый ответ на во Б1. Напишите программу, которая вычисляет квадрат наименьшего из четырёх чисел.

​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
twv05355
10.01.2024 08:09
А1. Программа – это:
Ответ: В) алгоритм, записанный с какого-либо языка программирования.
Обоснование: Программа представляет собой набор инструкций или алгоритм, записанный на каком-либо языке программирования, который выполняет определенные действия или решает задачу.

А2. Укажите верное обозначение массива.
Ответ: Г) Z[6…12]
Обоснование: Обозначение массива включает его имя и границы индексов. В данном примере, массив Z имеет индексы от 6 до 12.

А3. Как производятся все действия над одномерными массивами?
Ответ: Г) в цикле.
Обоснование: Для выполнения действий над одномерными массивами обычно используется цикл, который проходит по всем элементам массива и применяет необходимые операции.

А4. В программе описан одномерный целочисленный массив с индексами от 1 до 5. В приведённом ниже фрагменте программы массив сначала заполняется, а потом изменяется. Чему будут равны элементы этого массива?
Ответ: В) 11 9 7 9 11.
Обоснование: После заполнения массива по формуле A[i]:=2*i+1 получим: A[1] = 3, A[2] = 5, A[3] = 7, A[4] = 9, A[5] = 11. Затем при изменении массива во втором цикле A[i]:= A[6-i] получим: A[5] = 11, A[4] = 9, A[3] = 7, A[2] = 9, A[1] = 11.

А5. Алгоритм, целиком используемый в составе другого алгоритма, называется:
Ответ: Г) дополнительным.
Обоснование: Алгоритм, используемый в составе другого алгоритма, но при этом являющийся самостоятельным и необходимым для выполнения основного алгоритма, называется дополнительным.

А6. Подпрограмма, имеющая произвольное количество входных и выходных данных, называется:
Ответ: Б) функция.
Обоснование: Функция - это подпрограмма, которая принимает входные данные (аргументы), обрабатывает их и возвращает результат (выходные данные).

В заданиях группы Б приведите полное решение задачи или дайте развернутый ответ на вопрос Б1. Напишите программу, которая вычисляет квадрат наименьшего из четырех чисел.

Решение задачи:
Для вычисления квадрата наименьшего из четырех чисел, можно использовать следующий алгоритм:

1. Объявить четыре переменные для хранения четырех чисел.
2. Считать четыре числа с помощью оператора READ и сохранить их в соответствующих переменных.
3. Найти наименьшее число с помощью сравнения if и операторов сравнения (например, <) и сохранить его в отдельной переменной minNumber.
4. Вычислить квадрат наименьшего числа с помощью операции умножения (minNumber * minNumber) и сохранить результат в переменную square.
5. Вывести значение переменной square на экран с помощью оператора WRITE.

Пример программы на языке программирования Pascal выглядит следующим образом:

program SquareOfSmallest;
var
num1, num2, num3, num4, minNumber, square: integer;
begin
writeln('Введите четыре числа:');
readln(num1, num2, num3, num4);

minNumber := num1;

if num2 < minNumber then
minNumber := num2;
if num3 < minNumber then
minNumber := num3;
if num4 < minNumber then
minNumber := num4;

square := minNumber * minNumber;

writeln('Квадрат наименьшего числа:', square);
end.

Этот алгоритм позволяет найти наименьшее из четырех чисел и вычислить квадрат этого наименьшего числа.
0,0(0 оценок)
Ответ:
Ник1233211
16.03.2020 11:30

А

А

Б

В

Объяснение:

Ни хера не понемаю

0,0(0 оценок)
Ответ:
Annalove2000
16.03.2020 11:30

А - алгоритм

А2 - Б

А3 - А

А5-Б

А6-А

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота