Bong144
30.10.2022 20:29

написать программу в Паскале Хотя бы одну задачу

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mihailsokolenk
11.10.2020 22:09

PascalABC.NET

begin

 var a := ArrGen(10, i -> i in [0, 2, 6] ? 2 * (i + 1) + 10 :

     (i - 7) * 3);

 Writeln('массив');

 var m := a.Println.Where(p -> p.IsEven).Average;

 Write('sr=', m)

end.

begin

 var a := ArrGen(10, i -> (i + 1) mod 3 = 0 ? -i : Sqr(i + 2));

 Writeln('массив');

 var s := a.Println.Sum;

 Writeln('sr=', s);

 a.Transform(p -> p < 0 ? s : p);

 Writeln('новый массив');

 a.Print

end.

begin

 var a := ArrGen(15, i -> i < 7 ? i * (i + 6.1) + 5.1 : i - 4.7);

 Writeln('массив');

 foreach var k in a do

   Write(k:7:2);

 Writeln;

 var p := 1.0;

 for var i := 2 to 4 do

   p *= a[i];

 Write('p= ', p:0:3)

end.

Индексы в массивах PascalABC.NET идут не от единицы, а от нуля, как во всех современнных языках программирования. Поэтому исходные формулы пришлось немного преобразовать.

Примеры вывода не показаны, поскольку они точно совпадают с заданными.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота