noname298
11.09.2020 03:04

Написать программу которая выводит сумму чисел от 7 до 35 , кратных 7.
2) дано натуральное число N (кратно 4 ) и число х. Найдите сумму элементов последовательности х+8, х+12,..., х+N

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Кпоперша1
11.10.2020 22:03

1.

var i,s:integer;

begin

s:=0;

for i:=7 to 35 do

begin

 if i mod 7 = 0 then s:=s+i;

end;

writeln('Сумма кратных 7 на промежутке от 7 до 35 = ',s);

end.

2.

var S, N, x, i:integer;

begin

   write('Введите N = ');

   readln(N);

   write('Введите x = ');

   readln(x);

   S:=0;

for i:=2 to N div 4 do

begin

 S := S + (x + 4*i);

end;

writeln('Сумма = ', S)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота