Олиф1
18.02.2022 17:04

написать программу на Паскале для решения данной задачи или хотя бы подскажите алгоритм решения.
Дано три натуральных числа, не превышающих 32767. Определить, сколько из них имеют одинаковое количество цифр.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
илья1967
04.02.2023 19:53
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
uses System.Linq;
begin
    writeln('III');
    var a := ReadArrInteger('Документы', ReadInteger('n=')).ToList;
    writeln;
    
    while a.Any() do
    begin
        write(a[0], ' ');
        a.RemoveAt(0);
        if not a.Any then break;
        
        write(a.Last, ' ');
        a.RemoveAt(a.Count - 1);
        if not a.Any then break;
        
        var n := 0;
        if a.Count > 1 then n := a.Count div 2 - 1;
        write(a[n], ' ');
        a.RemoveAt(n);
    end;
end.
0,0(0 оценок)
Ответ:
nexsting1
07.01.2023 23:37
Компания Avira имеет около 100 миллионов клиентов и 300 сотрудников, она является ведущим мировым разработчиком решений по безопасности для профессионального и частного использования. Имея практически двадцатилетний опыт в этой области, компания является пионером в этой области.
Являясь ведущим немецким специалистом в области безопасности компания Avira имеет большой опыт разработки и поддержки своих решений. Наряду с программами для рабочего места компания предлагает профессиональные решения для комплексной защиты сетей на различных уровнях. Сюда, помимо прочего, относятся программы для рабочих станций, файловых серверов, серверов для электронной почты и веб-серверов. Даже шлюзовыми компьютерами можно управлять как и обычными компьютерами для рабочего места с центральной консоли управления для всей операционной системы. Помимо программ управления отдельными решениями существуют программы безопасности для PDA, смартфонов и встроенных устройств. Существенный вклад в безопасность вносит программа Avira AntiVir Personal, которая используется миллионами частных лиц.
Компания Avira, находящаяся в городе Теттнанг на Боденском озере является одним из самых крупных региональных работодателей. Она имеет несколько филиалов в Германии и партнеров в Европе, Азии и Америке. Несколько дюжин сотрудников в распределенных лабораториях круглые сутки борются с локальными и глобальными угрозами на поле битвы с вирусами. Эта работа подтверждается многократными наградами: VB 100% списка с вирусами или повторный сертификат от TЬV.
Являясь лидером технологий для Unix, компания Avira разрабатывает ответственные стандарты. К другим инновациям компании Avira относятся антивирусные программы для Symbian, а также первая в мире защита от вирусов с сертификатом SAP.
Наряду с интеллектуальными технологиями компания Avira под лозунгом „Больше, чем просто безопасность“ предлагает ориентированные на пользователей консультации и индивидуальную поддержку с собственных экспертов. Важный вкладом в безопасность и дополнительной защитой для сетей компаний является использование пользователями программы Avira AntiVir Personal.
Награды и сертификаты продукции Avira, а также сотрудничество с такими предприятиями, как IBM, Sun, Novell, AVM или Clearswift подчеркивают работо и компетентность компании. Решения компания Avira продаются во всем мире и благодаря обученным, авторизованным партнерам доступны везде.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота