chifire
27.10.2022 01:23

Составьте программу для целых чисел, введенных с клавиатуры
суммирующую четные числа мне нужно побыстрее...​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fffffffhhhhhh
08.05.2023 12:25
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
function IsHamming(n:integer):boolean;
begin
  while n mod 2 = 0 do n:=n div 2;
  while n mod 3 = 0 do n:=n div 3;
  while n mod 5 = 0 do n:=n div 5;
  Result:=(n=1)
end;

begin
  var n:=ReadInteger('n=');
  var s:int64:=0;
  var k:=0;
  var i:=2;
  while k<>n do begin
    if IsHamming(i) then begin
      Inc(k); s+=i; Print(i)
      end;
    Inc(i)
  end;
  Writeln(NewLine,'Сумма элементов последовательности равна ',s);
  n:=ReadInteger('Найти элемент с номером');
  i:=2; k:=0;
  while k<>n do begin
    if IsHamming(i) then Inc(k);
    Inc(i)
  end;
  Writeln('Найденное значение: ',i-1)
end.

Тестовое решение:
n= 33
2 3 4 5 6 8 9 10 12 15 16 18 20 24 25 27 30 32 36 40 45 48 50 54 60 64 72 75 80 81 90 96 100
Сумма элементов последовательности равна 1257
Найти элемент с номером 1000
Найденное значение: 51840000
0,0(0 оценок)
Ответ:
akrikay13
08.05.2023 12:25

#include <iostream> // iostream

int main() { // int main

int N; // N

int M; // M

int sum = 0; // сумма чисел хэмминга от n до m

std::cout << "N: "; // запрашиваем N

std::cin >> N;

std::cout << "M: "; // запрашиваем M

std::cin >> M;  

int *hemming = new int[M - N + 1]; // массив с числами хемминга

int counter = 0; // размер массива

for (int i = N; i <= M; ++i) { // записываем числа в массим хемминга

 if (i % 2 == 0 || i % 3 == 0 || i % 5 == 0) { // если остаток от деления

  std::cout << i << " "; // на 2 или 3 или 5 равен нулю

  hemming[counter] = i; // и выводим.  

  sum += hemming[counter]; // прибавляем к сумме числа

  ++counter; // увеличиваем счётчик

 }

}

std::cout << std::endl << sum; // выводим сумму

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота