sergo3g123g
02.04.2020 06:41

С++ отсортировать массив по неубыванию методом вставок.
В первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. Во второй строке задаются N чисел – элементы массива (целые числа, не превосходящие по модулю 1000).
Выходные данные
Вывести получившийся массив.

Примеры
входные данные
5
5 4 3 2 1
выходные данные
1 2 3 4 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kirinjindosh12
18.02.2021 13:14

В информатике выделяются два направления – теоретическое и прикладное. Исследования в области теоретической информатики обеспечивают выявление и формулировку общих законов, касающихся информации и информационных процессов; определение принципов функционирования технических систем, связанных с информационными процессами и обработкой дискретной информации, а также построение методологии создания и применения информационных моделей. Прикладная информатика обеспечивает непосредственное создание информационных систем и программного обеспечения для них, а также их применение для решения практических задач.

В данных методических указаниях рассматриваются теоретические основы дисциплины «Информатика».

Теоретическая информатика – дисциплина, использующая методы математики. Поскольку любая информация может быть представлена в дискретном виде, для описания информационных процессов может быть применен аппарат дискретной математики, в частности, теория автоматов и алгоритмов, теория графов, теория формальных языков и грамматик, алгебра логики, теория информации и др.

Вся информация, которая попадает в компьютер, преобразуется в последовательность электрических импульсов. Наличие импульса принято условно обозначать «1», а его отсутствие – «0». Такой кодирования информации называется двоичным, или бинарным. Один двоичный символ получил название бит (bit – от английского – двоичная цифра). Таким образом, двоичное кодирование – это представление информации при минимально возможного числа элементарных символов. Двоичное кодирование автоматически дает кодирования информации любого вида (числовой, символьной, логической, графической, звуковой) в двоичной системе счисления.

1. ПРЕДСТАВЛЕНИЕ ЧИСЛОВОЙ ИНФОРМАЦИИ

Существует два основных формата представления чисел в памяти ком­пьютера, один из них применяется для кодирования целых чисел (представление числа в формате с фиксированной точкой), второй – для задания некоторого подмножества действительных чисел (представление числа в формате с плавающей точкой). Рассмотрим каждый из форматов подробнее.

1.1. Представление целых чисел

Любое целое число можно рассматривать как вещественное, но с нулевой дробной частью, т. е. можно было бы ограничиться представлением в компьютере вещественных чисел и реализацией арифметических операций над ними, однако для эффективного использования памяти ЭВМ, повышения скорости выполнения вычислений и введения операции целочисленного деления целые числа представляются специально для них предназначенными

Для компьютерного представления целых чисел обычно применяются несколько различных отличающихся друг от друга количеством двоичных разрядов и наличием или отсутствием знакового разряда.

Целые числа в компьютере хранятся в памяти в формате с фиксированной запятой. В этом случае каждому разряду ячейки памяти соответствует всегда один и тот же разряд, а «запятая» «находится» справа после младшего разряда, т. е. вне разрядной сетки.

1.1.1. Целые числа без знака

Рассмотрим кодирование целых чисел без знака на примере данных типа byteв языкеBasicиunsigned charв языкеС++, занимающих в памяти один байт.

Для получения компьютерного (внутреннего) представления однобайтового целого неотрицательного числа достаточно перевести его в двоичную систему счисления и полученный результат, называемый прямым кодом числа, дополнить слева нулями до восьми битов.

Минимальное число представляется нулями во всех разрядах и равно нулю. Максимально представимому числу соответствуют единицы во всех разрядах ячейки (двоичное число, состоящее из восьми единиц), оно равно 255 (). Примеры кодирования однобайтовых целых чисел без знака приведены в табл. 1.

Однобайтовые целые неотрицательные числа могут применяться, например, для организации различных счетчиков, записи адресов ячеек, даты и времени, размеров графических изображений в пикселях.

Для улучшения читаемости внутреннего представления числа его записывают в шестнадцатеричной системе счисления.

0,0(0 оценок)
Ответ:
ekaterina5velikaya
19.01.2021 04:32
//Dev-C++ 5.11

#include <stdio.h>
int main(void)
 {float a[10][10]={0},newar[100]={0},min=2147483647;
 int i,j,n,c,coucurr=1,newn=0,boo=0;
 scanf("%d",&n);
 for(i=0;i<n;i++)
  for(j=0;j<n;j++)
   {scanf("%f",&a[i][j]);
   newar[newn]=a[i][j];
   newn++;}
 for(i=0;i<newn;i++)
  {for(j=0;j<newn;j++)
   if (newar[i]==newar[j] && i!=j)
    coucurr++;
  if (coucurr>1 && min>newar[i])
   {min=newar[i]; boo=1;}
  coucurr=1;}
if(boo)
 printf("%f",min);
else
 printf("Nothing");
 return 0;}

Пример ввода:
3
1
2
2
3
3
3
4
4
4
Пример вывода:
2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота