Iriska91l23
22.06.2020 01:58

НАПИШИТЕ ПРОГРАММУ НА Python
Обозначим дни недели числами от 1 (понедельник) до 7 (воскресенье) соответственно. По известному m — дню недели первого числа текущего месяца — определите день недели числа n. На вход программе подаются 2 целых числа 1≤n≤31, 1≤m≤7, каждое в отдельной строке. Выведите день недели числа n.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zarinazaac30
31.12.2021 20:13
        public static void SayHello()
        {
            Console.WriteLine("Как тебя зовут?");
            var name = Console.ReadLine();
            Console.WriteLine($"Привет, {name}!");
            Console.ReadLine();
        }

        public static bool IsPalindrom(string s)
        {
            Debug.Assert(s.Length > 0);
            s = s.ToLower(); // Переводим все буквы в строчные, чтоб регистр нам не мешал
            s = Regex.Replace(s, @"\W", ""); //Заменяем все символы которые не являются буквами или цифрами на пустую строку
            return ((string) s.Reverse() == s); //Пеереворачиваем строку и сравниваем с исходной
        }

Полный код в присоединенном файле
0,0(0 оценок)
Ответ:
Белялова
28.08.2021 05:39
Для удобства вычислений переведём размер сканируемого изображения в дюймы: 20,32 × 20,32 (см) = 8 × 8 (inch).

Сначала найдём количество пикселей по горизонтали, по вертикали, затем общее количество пикселей, исходя из разрешающей сканера. Зная, что каждый пиксель кодируется 4 битами, найдём объём памяти, необходимый  для хранения графической информации, что и будет являться информационным объёмом файла.

1)    600 × 8 = 4800 (px) – количество пикселей по горизонтали.

2)    1200 × 8 = 9600 (px) – количество пикселей по вертикали.

3)    4800 × 9600 = 46 080 000 (px) – всего пикселей.

4)    46 080 000 × 4 = 184 320 000 (bit) = 22 500 (KB)

ответ: полученный графический файл будет иметь объём 22 500 килобайт.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота