Samatova03
14.02.2021 11:32

Python
Определите, верно ли, что в заданном четырехзначном числе ровно две одинаковые цифры.

Входные данные

На вход подается целое число k (1000≤k≤9999)

Выходные данные

Выведите 1 при положительном ответе на во задачи и любое другое целое число в противном случае.
Нельзя использовать if, while, abs
Только через //,%,*,/,+,-​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
goldin1337
22.07.2020 18:43
Клавиатура — компьютерное устройство, которое располагается перед экраном дисплея и служит для набора текстов и управления компьютером с клавиш, находящихся на клавиатуре.Клавиатура позволяет вводить в компьютер числовую и текстовую информацию, а также различные команды и данные. Раскладка на клавиатуре придумана исходя из часто используемых комбинаций букв. Так, например, буква "Ё" вынесена отдельно от остальных, ибо ее используют редко. По своему назначению клавиши на клавиатуре условно делятся на основные группы: буквенно-цифровые клавиши,клавиши цифровой клавиатуры,клавиши управления, клавиши-модификаторы, функциональные клавиши, клавиши управления курсором. Буквенно-цифровые клавиши также именуются алфавитно-цифровыми клавишами, клавишами данных, клавишами для ввода данных. Клавиши управления предназначены для выполнения определенных действий. Они могут использоваться отдельно или в сочетании с другими клавишами.
Помимо обычных клавиатур со стандартным набором данных бывают:
- мультимедийные клавиатуры:
  помимо стандартного набора из 104 клавиш, снабжаются дополнительными клавишами (как правило, другого размера и формы), которые предназначены для упрощённого управления некоторыми основными функциями компьютера
- программируемые клавиатуры:
 Разработаны клавиатуры, в которых назначение и внешний вид клавиш изменяется программным образом в зависимости от выбранного набора символов и даже от запущенного в текущий момент приложения.
0,0(0 оценок)
Ответ:
dgutjhththgjtjth
17.02.2020 07:01
Код ужасно кривой, но рабочий (надеюсь, принцип понятен):
1. Бензин
type
  Benzin=class
    public
    money:double;
    m:integer;
     
end;
  var
    b:Benzin;

begin
  b:=new Benzin;
  b.m:=0;
  b.money:=20;
  while b.money<22.0 do
  begin
  b.money:=b.money*1.02;
  b.m:=b.m+1;
  writeln('Сейчас бензин стоит: ',b.money);
  writeln('Сейчас месяц
  end;
 
end.

2. Вклад
type
  biznes=class
    public
    money:double;
    m:integer;
    time:integer;
     
end;
  var
    b:biznes;

begin
  b:=new biznes;
  writeln('Напишите сумму рублей: ');
  read(b.money);
  writeln('Напишите кол-во месяцев: ');
  read(b.m);
  b.time:=0;
  while b.time<b.m do
  begin
  b.money:=b.money*1.03;
  b.time:=b.time+1;
  writeln('Сейчас сумма: ',b.money);
месяц: ',b.time);
end;
 
 
 
end.

3. Тренировки
type
  sport=class
    public
    first:double;
    day:integer;
    first2:double;
    first3:double;
    first4:double;
    first5:double;
    first6:double;
    first7:double;
    answer:double;
     
end;
  var
    s:sport;

begin
  s:=new sport;
  s.first:=5;
  s.day:=1;
 
  while s.day=1 do
  begin
  s.first2:=s.first*1.20;
  s.day:=s.day+1;
  writeln('Сейчас бегает: ',s.first2);
  writeln('День: ',s.day);
  end;
  while s.day=2 do
  begin
  s.first3:=s.first2*1.20;
  s.day:=s.day+1;
  writeln('Сейчас бегает: ',s.first3);
  writeln('День: ',s.day);
  end;
  while s.day=3 do
  begin
  s.first4:=s.first3*1.20;
  s.day:=s.day+1;
  writeln('Сейчас бегает: ',s.first4);
  writeln('День: ',s.day);
  end;
  while s.day=4 do
  begin
  s.first5:=s.first4*1.20;
  s.day:=s.day+1;
  writeln('Сейчас бегает: ',s.first5);
  writeln('День: ',s.day);
  end;
  while s.day=5 do
  begin
  s.first6:=s.first5*1.20;
  s.day:=s.day+1;
  writeln('Сейчас бегает: ',s.first6);
  writeln('День: ',s.day);
  end;
  while s.day=6 do
  begin
  s.first7:=s.first6*1.20;
  s.day:=s.day+1;
  writeln('Сейчас бегает: ',s.first7);
  writeln('День: ',s.day);
  end;
  while s.day=7 do
  begin
  s.answer:=s.first+s.first2+s.first3+s.first4+s.first5+s.first6+s.first7;
  s.day:=s.day+1;
  writeln('ответ: ',s.answer);
  end;
 
 
 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота