русанин
31.03.2023 04:58

Дорожная карта у программиста Васи записана как матрица смежности графа. Напишите программу, которая Васе определить, верно ли, что из первого города можно проехать во все остальные (не обязательно напрямую).

Входные данные
В первой строке вводится количество городов на карте N ( 1 ≤ N ≤ 1000 ). В следующих N строках записано по N чисел, разделённых пробелами – элементы матрицы смежности графа, который описывает схему дорог.

Выходные данные
Программа должна вывести слово 'YES', если из первого по порядку города можно проехать во все остальные, и 'NO', если это не так.

входные данные
5
0 1 1 1 0
1 0 1 0 1
1 1 0 1 0
0 0 0 0 0
0 1 0 1 0
выходные данные
YES

-

входные данные
5
0 1 1 0 0
1 0 1 0 0
1 1 0 0 0
0 0 0 0 1
0 0 0 1 0
выходные данные
NO

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ARDASHEV2019
16.06.2022 02:17
C#
int n = Convert.ToInt32(Console.ReadLine());
int max = 0;
int index = -1;
int [] mass = new int [n];
Random rnd = new Random();

for (int i = 0; i< mass.Length; i++)
{
mass[i] = rnd.Next();
Console.WriteLine(mass[i] + " ");
}

for (int i = 0; i < mass.Length; i++)
{
if (mass[i] > max)

max = mass[i];
index = i;
}
}
Console.WriteLine("Индекс наибольшего равен " + index);

короч просто описываю что надо:
1) Заводишь переменные для максимума и индекса
2) Заполняешь массив рандомными числами
3) выводишь массив
4) пробегаешь по массиву, сверяя элементы с максимумом
- если max меньше элемента, то присваиваешь ему элемент и запоминаешь в index номер элемента
5) выводишь индекс элемента

в коде все понятно будет, я думаю
но я думаю вам нужен паскаль, но на паскале я не могу с массивами, не люблю я их.
0,0(0 оценок)
Ответ:
erenina88
16.06.2022 02:17
C#
int n = Convert.ToInt32(Console.ReadLine());
int max = 0;
int index = -1;
int [] mass = new int [n];
Random rnd = new Random();

for (int i = 0; i< mass.Length; i++)
{
mass[i] = rnd.Next();
Console.WriteLine(mass[i] + " ");
}

for (int i = 0; i < mass.Length; i++)
{
if (mass[i] > max)

max = mass[i];
index = i;
}
}
Console.WriteLine("Индекс наибольшего равен " + index);

короч просто описываю что надо:
1) Заводишь переменные для максимума и индекса
2) Заполняешь массив рандомными числами
3) выводишь массив
4) пробегаешь по массиву, сверяя элементы с максимумом
- если max меньше элемента, то присваиваешь ему элемент и запоминаешь в index номер элемента
5) выводишь индекс элемента

в коде все понятно будет, я думаю
но я думаю вам нужен паскаль, но на паскале я не могу с массивами, не люблю я их.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота