ковязин14
27.04.2023 18:40

НА ПИТОНЕ 3 ТОЛЬКО АРИФМЕТИЧЕСКИМИ ОПЕРАЦИЯМИ!

Имеется n кг металлического сплава. Из него изготавливают заготовки массой k кг каждая. После этого из каждой заготовки вытачиваются детали массой m кг каждая (из каждой заготовки вытачивают максимально возможное количество деталей). Если от заготовок после этого что-то остается, то этот материал возвращают к началу производственного цикла и сплавляют с тем, что осталось при изготовлении заготовок. Если того сплава, который получился, достаточно для изготовления хотя бы одной заготовки, то из него снова изготавливают заготовки, из них — детали и т.д.

Напишите программу, которая вычислит, какое количество деталей может быть получено по этой технологии из имеющихся исходно n кг сплава.

Программа получает на вход три натуральных числа n, k, m, каждое в отдельной строке, при этом m≤2×10^9,k≤2×10^9,n≤2×10^9.

Выведите одно число — количество деталей, которое может получиться по такой технологии.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lizamog1
08.01.2021 16:46

1)а

var a:real;

begin

readln(a);

a1 := a*a;  /получили а^2
a := a1*a1;  /получили a^4

a := a1*a*a;  /получили a^(4+4+2)

writeln(a);

end.

 

1б)

var x:real;

i:integer;

begin

readln(a);

a1 := a*a*a;  /получили а^3
a := a1*a1*a1;  /получили a^9

a := a*a1*a1; /получили а^(9+3+3)

writeln(a);

end.

 

2)

var a:real;
begin
readln(a);
writeln('высоты равны', a*a*sqrt(3)/4*a);
writeln('Радиус вписанной окружности', a*a*a/4*a*a*sqrt(3)/4);
writeln('Радиус описанной окружности', a*a*sqrt(3)/4*2/3*a);
end.

 

3)var a:real;
begin
readln(a);

writeln('В килобайтах' a/1024);

writeln('В мегабайтах' a/(1024*1024));

end.

0,0(0 оценок)
Ответ:
yuliayatseniuk1
08.01.2021 16:46
Код#include <iostream>constexpr double bites_to_megabytes(double a) {    return a / 8388608;}constexpr double megabytes_to_gigabytes(double a) {    return a / 1024;}int main() {    long long a;    short type;    bool is_correct = false;    double answer;    do {        std::cin >> a;        std::cout << "[1] Megabytes \n"                  << "[2] Gigabytes \n"                  << "Convert to [1] or [2]: ";        std::cin >> type;        if (type == 1 or type == 2) {            is_correct = true;        } else {            std::cout << "Meh. Try to type again. \n" << std:: endl;        }    } while (!is_correct);    switch (type) {        case 1:            answer = bites_to_megabytes(a);            break;        case 2:            answer = megabytes_to_gigabytes(bites_to_megabytes(a));            break;    }    std::cout << "An answer of conversion is " << answer << std::endl;    return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота