girlmarta
11.08.2022 00:56

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 1000 .

Выходные данные
Программа должна вывести элементы полученного массива в одной строке, разделив их пробелами.

Примеры
входные данные
6
6 2 1 5 3 4
выходные данные
1 2 3 6 5 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Вова1337228
13.10.2021 19:46
Const n=5;
var
   i,j,pa,pb,pc,pd:integer;
   a,b,c,d:array[1..n,1..n]of integer;

function prost(n:integer):integer;
begin
var i:integer;
result:=0;
for i:=2 to n div 2 do
  if n mod i=0 then
    begin
    result:=1;
    break;
    end
end;

procedure otvet(p:integer; s:string);
begin
if p=0 then writeln('На диагоналях матрицы ',s,' есть простые числа')
   else writeln('На диагоналях матрицы ',s,' нет простых чисел');
end;

begin 
pa:=1; 
pb:=1; 
pc:=1; 
pd:=1;
writeln('Массив А':18,'Массив B':18,'Массив C':18,'Массив D':18);
for i:=1 to n do
   begin
   for j:=1 to n do
     begin
     a[i,j]:=random(100,900);
     b[i,j]:=random(100,900);
     c[i,j]:=random(100,900);
     d[i,j]:=random(100,900);
     if (i=j) or (j=n+1-i) then
        begin
        pa:=pa*prost(a[i,j]);
        pb:=pb*prost(b[i,j]);
        pc:=pc*prost(c[i,j]);
        pd:=pd*prost(d[i,j]);
        end;
     end;
   end;
for i:=1 to n do
  begin
  for j:=1 to n do write(a[i,j]:4);
  write('|');
  for j:=1 to n do write(b[i,j]:4);
  write('|');
  for j:=1 to n do write(a[i,j]:4);
  write('|');
  for j:=1 to n do write(a[i,j]:4);
  write('|');
  writeln;
  end;  
otvet(pa,'A');
otvet(pb,'B');
otvet(pc,'C');
otvet(pd,'D');
end.
0,0(0 оценок)
Ответ:
artemvershinin
24.01.2023 00:35
1. Что такое модель?
Модель — упрощенное представление о реальном объекте, процессе или явлении.

1. Назовите основные свойства моделей. 
Модели воспроизводят существенные свойства оригинала. 
Одному объекту могут соответствовать несколько моделей.
Вид модели определяется целью моделирования.

2. Что такое моделирование?
Процесс создания модели.

3. Как можно назвать отношения между объектом-оригиналом и его моделью?
Модель — уменьшенная копия оригинала.

4. Какие модели называют натурными? Приведите 2-3 примера натурных моделей. 
Натурные модели — модели, воспроизводящие свойства прототипа. Примеры: манекен — модель человека, корабль в бутылке — модель настоящего корабля.

5. Какие модели называют информационными? Приведите 2-3 примера информационных моделей. 
Информационные модели — модели, описывающие свойства прототипа. Примеры: схема компьютера, описание природы.

6. Для каждой из перечисленных моделей назовите действия, которые человек может выполнить и с ней, и с  объектом-оригиналом: 
1) радиоуправляемая модель самолета;
* смотреть на объект
* сжечь
* управлять полётом

2) словесное описание куртки;
* представить
* обсудить

3) план квартиры;
* представить
* обсудить

4) чайник из пластилина в натуральную величину;
* смотреть
* фотографировать

5) мысленное представление о будущей поездке.  
* размышлять

Какие действия могут быть выполнены только с оригиналом?
1) залесть внутрь
2) надеть
3) зайти, жить внутри
4) кипятить воду
5) отдохнуть, сделать фотографии
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота