ира1029
09.02.2022 08:38

Мальчик Вася делает домашнее задание за t минут. Написать программу на Pascal для определения: сколько бы ему понадобилось школьных уроков без перемен, чтобы выполнить это задание в школе.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dendemintsev
01.11.2022 21:13

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int n;

cin >> n;

char* string1 = new char[n];

char* string2 = new char[n];

cin >> string1;

cin >> string2;

bool check = true;

if (strlen(string1) != strlen(string2))  

 cout << "Неверное количество символов";

else

{

 for (size_t i = 0; i < round(strlen(string1) / 2); i++) {

  if (string1[i] != string2[i]) {

   check = false;

  }

 }

 if (check)

  cout << "Первые половины равны";

 else

  cout << "Половины первые не равны";

}

}

0,0(0 оценок)
Ответ:
po4emy228
07.07.2020 13:16
Обьясняется различие в размерах файлов тем, что разные кодировки используют разное кол-во памяти, к примеру обычный *.txt файл хранит просто упорядоченный набор символов, а *.rtf уже хранит такие характеристики как размер шрифта цвет выравнивание и много других параметров. Разные расширения текстовых данных сделаны для хранения максимального кол-ва данных в наименьшем возможном ко-во памяти (txt), и наоборот хранения текста в исходном виде с исходными характеристиками (rtf). Ну а размеры файлов можешь и сам посмотреть сделав эту лабу. Эхх... бывают же ленивые люди(((
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота