Vladijad
26.11.2021 04:22

написать программу на Java !
Какова N-я перестановка цифр 0 1 2 3 4 5 6 7 8 9, если предположить, что их генерировали в лексикографическом порядке?
На вход подается N
Выход 10 цифр без пробелов – перестановка под номером n
Входные данные
1
Выходные данные
0123456798
Входные данные 2
2
Выходные данные 2
0123456879

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SkvidLe
05.05.2021 18:02

В коде программы были ошибки, я их подправил. Вот исправный код:

program pr1;

var s,a:string; i:integer;  //объявляем переменные

begin

   s:='1234';  //исходная строка

   a:='';        //заполняемая строка для вывода

   for i:= length(s) downto 1 do    //от длины исходного списка "s" до 0

       a:=a+s[i]+a;    //добавляем к списку "a" новый символ из списка "s" и после этого символа добавляем строку "a"

   writeln(a)      //выводим список "a"

end.

Этот код берёт из строки s символ и добавляет его в конец строки a и после этого символа добавляет строку а.

Для понимания, что происходит в каждой строке кода, я закоментил прогу.

Если остались вопросы, пишите кометарии, я отвечу.


ДАЮ МАКС КОЛ-ВО program pr1; var s:string; i:=integer; begin s:='1234'; a:=''; for i:= length(s) do
0,0(0 оценок)
Ответ:
BlackStar14
14.08.2020 17:16

Алфави́т формального языка — множество атомарных (неделимых) символов какого-либо формального языка (иногда их называют буквами по аналогии с алфавитами естественных языков или символами). Из символов алфавита формального языка строятся слова, а заданием формальной грамматики — допустимые выражения языка.

Лексемы образуются из символов, выражения — из лексем и символов, а операторы — из символов, выражений и лексем. В этой записи рассмотрен алфавит языка программирования

Интегрированная среда разработки - комплексное средство, включающее всё необходимое программисту для создания программного обеспечения.

Алгоритм, в котором команды выполняются в порядке их записи, то есть последовательно друг за другом, называется линейным.

Спецификация (определение, формулирование требований к программе).

Разработка алгоритма.

Кодирование (запись алгоритма на языке программирования).

Отладка.

Тестирование.

Создание справочной системы.

Создание установочного диска (CD-ROM).

6) Вопрос посмотри фото


Уровень — Знание и понимание 1.Что такое алфавит языка?2. Из чего формируются лексемы?3. Что такое и
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота