АРТЕМІДА555
30.12.2020 01:01

1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числами
в диапазоне (0,10), выводит его на экран, а затем выводит на экран квадраты всех элементов
массива.
Пример:
Массив: 5 6 2 3 1 4 8 7
Квадраты: 25 36 491 16 64 49
.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kense
11.10.2020 15:47

C# 8.0:

using System;

...

var Arr = RandomIntArr(0,10,8);

foreach(int i in Arr) Console.Write(i+" ");

Console.WriteLine();

foreach(int i in Arr) Console.Write(i*i + " ");

...

static int[] RandomIntArr(int Min, int Max, int ArrLen) {

  Random rnd = new Random();

  int[] Out = new int[ArrLen];

  for (int i = 0; i < ArrLen; i++)  Out[i] = rnd.Next(Min, Max+1);

  return Out;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота