Diman66666
24.04.2023 03:14

5. Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке
[-2; 2] и находит произведение ненулевых элементов ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
boosoosv
11.10.2020 15:47

C# 8.0:

using System;

using System.Linq;

...

var Arr = RandomIntArr(-2,2,10);

Console.WriteLine(Arr.Where(x=>x!=0).Aggregate((x,y)=>x*y));

...

static int[] RandomIntArr(int Min, int Max, int ArrLen) {

   Random rnd = new Random();

   int[] Out = new int[ArrLen];

   for (int i = 0; i < ArrLen; i++)  Out[i] = rnd.Next(Min, Max+1);

   return Out;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота