SeyshellaGoa
13.10.2020 02:41

Можно ли написать программу для Удвоителя, которая из любого числа x строит число 7x+9?Почему?

Заполните пропуск: «Можно написать программу для Удвоителя, которая из любого числа x строит число a·x+b, где a и b

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katya200513
16.09.2021 19:39
// PascalABC.NET 3.0, сборка 1076
begin
  var n:=ReadInteger('Число элементов массива=');
  var a:=ArrRandom(n,-25,25);
  Write('Исходный массив: '); a.Println;
  var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
  if k>0 then Writeln
    ('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
  else Writeln
    ('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.

Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого
0,0(0 оценок)
Ответ:
asino20145
16.03.2022 23:10
Дешифровка: ВХОД_ОТКР Ы Т.

дешифровки:
Const sh = '_.,';
Var
  St : String;
  i  : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
  For j:=1 to Length(S) do
  Begin
    n:=Pos(S[j],sh);
    If n>0 then
    Begin
      n:=n+k;
      While n>Length(sh) do n:=n-Length(sh);
      While n<=0 do n:=n+Length(sh);
      S[j]:=sh[n];
    end
  end;
  DeCode:=S;
end;
Begin
  St:='ЗЫФЙГФШРЦ . ШД';
  Writeln(Decode(St,sh,-6));
  //For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота