m20m
26.06.2020 14:09

Нужно написать программу на Java
Дана матрица размера M × N. Найти максимальный среди минимальных элементов ее строк. Есть код на Паскале

const
rows = 10; { <-- Количество строк }
columns = 10; { <-- Количество столбцов }

var
A: array[1..rows, 1..columns] of integer;
i, j, M, N: byte;
MinElem, MaxMinElem: integer;

begin
repeat
write('M = ');
readln(M)
until (M >= 1) and (M <= rows); { <-- Количество строк от 1 до rows }
repeat
write('N = ');
readln(N)
until (N >= 1) and (N <= columns); { <-- Количество столбцов от 1 до columns }
{ Формируем и выводим матрицу: }
randomize;
writeln('Случайная матрица ', M, 'x', N, ':');
for i := 1 to M do begin
for j := 1 to N do begin
a[i, j] := -100 + random(200); { <-- Случайный элемент -100..99 }
write(a[i, j]:4);
if j = 1 then MinElem := a[i, j] { <-- Инициализация минимального элемента }
else { Сравниваем остальные элементы с минимальным: }
if a[i, j] < MinElem then MinElem := a[i, j]
end;
if i = 1 then MaxMinElem := MinElem { <-- Инициализация максимального минимума }
else
if MinElem > MaxMinElem then MaxMinElem := MinElem;
writeln
end;
writeln;
writeln('Максимальный среди минимальных элементов строк: ', MaxMinElem);
readln
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Artyom2005738282
28.07.2020 07:20
Разделим число 89 на два ( 2 - это основание системы счисления). Делить будем с остатком, частное запишем в столбец "Част.", а остаток в столбец "Ост.". Затем полученное частное снова разделим на два и новое частное и остаток также распределим по столбцам (см. ниже). Повторять деление будем до тех пор, пока последнее частное не окажется меньше двух. Част. Ост. 89 : 2 = 44 1 44 : 2 = 22 0 22 : 2 = 11 0 11 : 2 = 5 1 5 : 2 = 2 1 2 : 2 = 1 0 Теперь мы можем записать число 89 в двоичной системе счисления. Для этого в старший (самый левый) разряд числа запишем последнее частное (выделено жирным), а в следующие, по порядку, разряды запишем все полученные выше остатки, беря их снизу вверх. То есть, в самом младшем разряде оказывается самый верхний остаток. ответ: 89= 1011001
0,0(0 оценок)
Ответ:
ilyagnomm
29.09.2020 16:53
Алфавитный (иначе, лексикографический) порядок - такой, при котором слово 1 стоит раньше в словаре, чем слово 2, если первые m ≥ 0 букв у этих слов совпадают, а (m + 1)-ая буква первого слова стоит в алфавите раньше, чем (m + 1)-ая буква второго слова.

Будем записывать "стоит раньше" привычным значком <, тогда, например, для обычного русского алфавита A < Б < В < Г < ... < Я.

Посмотрим на первые буквы мишиных слов:
А...
Б...
Б...
Б...
З...
З...

Из уже написанного можно сделать вывод, что A < Б < З.

Сравним первые три буквы слов, начинающихся на Б:
БАР...
БАР...
БАН...

Поскольку 2 первые буквы одинаковы, а слова, у которых на третьем месте стоит Р, стоят раньше, чем слово, у которого Н, получаем, что Р < Н.

Продолжаем исследовать слова БАРАНКА и БАРАБАН. Выписывая первые буквы вплоть до первой отличающейся, получаем
БАРАН...
БАРАБ...

Отсюда Н < Б.

Осталось разобраться с двумя словами, начинающимися на З. Так как они начинаются на 
ЗН...
ЗА...

то Н < А.

Итак, требуется решить систему неравенств:
A < Б < З
Р < Н
Н < Б
Н < А

Легко понять, что в данном случае Р < Н < А < Б < З.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота