ac123sjdjhdndndndh
18.04.2022 11:19

Составить программу в Паскале, которая выводит матрицу вот по этой штуке

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
MaxCraft670
13.11.2020 04:07
Дано a=82_{16}, b=701_8. Выберите число с, записанное в двоичной системе, которое отвечает условию a<c<b.
Число в 16-ой и 8-ой системе очень легко записать в двоичное системе расписав каждую цифру числа на черыре цифры у 16-го числа и на три цифры у 8-го числа
Первое число 82(в 16)
8 =1000(в двоичной системе)
2= 0010
82 =10000010
Второе число 701(в 8 системе)
7=111( в двоичной системе)
0=000
1=001
701=111000001
Данные системы счисления относятся к позиционным поэтому вес каждой цифры зависит от ее положения
Число с удолетворяющее условию a<c<b равняется 11010111
11010111(2) =327(8)=D7(16)
0,0(0 оценок)
Ответ:
Асия2008
05.03.2021 12:18
Const c:array [1..10] of integer = (-7,3,0,2,-1,4,8,-9,1,6);
var b,d:array [1..10] of integer;
     p,k,max,i,j,tmp:integer;
begin
  p:=1;
  for i:=1 to 10 do
    if c[i] > 0 then p:=p*c[i];
  k:=0;
  for i:=1 to 10 do
    if c[i] < 0 then inc(k);
  d:=c;
  max:=d[1];
  for i:=2 to 10 do
    if c[i] > max then max:=c[i];
  writeln ('Max: ',max);
  writeln ('Kol-vo otriz. elementov: ',k);
  writeln ('Proizvedenie: ',p);
  for i:=1 to 10 do
    if c[i] >= 0 then b[i]:=c[i]+10 else
      if c[i] < 0 then b[i]:=c[i]*c[i];
  writeln ('New massiv: ');
  for i:=1 to 10 do write (b[i],' ');
  writeln;
  for i:=1 to 9 do
    for j:=i+1 to 10 do
      if d[j] > d[i] then
       begin
         tmp:=d[j];
         d[j]:=d[i];
         d[i]:=tmp;
       end; 
  for i:=1 to 10 do write (d[i],' ');
  writeln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота