dikozzz
15.01.2022 16:24

желательно объяснить что и как делать)
Задание :Составить программу на Паскале, которая проверяет является ли фраза
"палиндром" Фраза моя "ДеД" можете свою, а там уже вставлю я свою)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alenagalcheva
10.03.2022 10:53

ответ:Внутри условных инструкций можно использовать любые инструкции языка Питон, в том числе и условную инструкцию. Получаем вложенное ветвление – после одной развилки в ходе исполнения программы появляется другая развилка. При этом вложенные блоки имеют больший размер отступа (например, 8 пробелов). Покажем это на примере программы, которая по данным ненулевым числам x и y определяет, в какой из четвертей координатной плоскости находится точка (x,y):

x = int(input())

y = int(input())

if x > 0:

   if y > 0:               # x>0, y>0

       print("Первая четверть")

   else:                   # x>0, y<0

       print("Четвертая четверть")

else:

   if y > 0:               # x<0, y>0

       print("Вторая четверть")

   else:                   # x<0, y<0

       print("Третья четверть")

В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

Объяснение:В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

0,0(0 оценок)
Ответ:
dymovvla01928
09.11.2022 09:57

Name : c_file_row_count.c

Author : UranFlex

Version : 0.1 alpha

Copyright : GNU GPL

Description : В файле input.txt записана информация из нескольких текстовых строк. Выводим содержимое этого файла на экран, посчитаем количество строк в файле.

#include <stdio.h>

#include <stdlib.h>

#define FNAME "input.txt" // имя исходного файла

int main( void ) {

// пробуем открыть файл для чтения

FILE* in = fopen( FNAME, "r" );

// обрабатываем ошибку открытия файла

if ( in == NULL ) {

perror( "Ошибка при открытии исходного файла" );

return EXIT_FAILURE;

}

size_t counter = 0; // предполагаем, что строк ноль в файле - т.е. пустой

int ch, pre = EOF; // текущий символ, последний считаный символ

printf( "%s %s\n", "Содержимое файла", FNAME );

// в цикле считаем сколько переводов строки в файле и запоминаем это в переменную counter

// а также выводим на экран каждый считаный символ.

// если файл пустой, то тело цикла не выполнится ни разу, так как первый считанный символ будет как раз EOF

// и в pre останется EOF

while ( ( ch = fgetc( in ) ) != EOF ) { // в цикле проходим весь файл посимвольно

pre = ch; // запоминаем последний считаный символ

if ( ch == '\n' ) // если нашли перевод строки,

++counter; // то увеличиваем счетчик строк

putchar( ch ); // выводим очередной символ на экран

}

// весь смысл переменной pre в том, чтобы запомнить какой символ мы считали перед тем как наткнулись на EOF в файле

// или в pre будет EOF - если тело цикла ни разу не выполнилось, это будет при пустом файле

// последняя строка файла может заканчиваться не \n, а строку посчитать надо - вот для этого и нужна переменная pre.

if ( pre == EOF ) // если файл пустой

puts( "Файл пустой!" ); // информация об этом.

else if ( pre != '\n' ) { // pre содержит в себе не перевод строки, и файл не пустой.

++counter; // увеличиваем

puts( "" );

}

puts( "" );

// выводим на экран информацию о количестве строк

printf( "%s %s %d", "строк в файле", FNAME, counter );

return EXIT_SUCCESS;

Объяснение:

Сейчас решаем такую же задачу, только на олимпиаде, вроде так.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота