Aleshchksuni
29.05.2023 01:22

нужно написать программу на языке программирования Pascal для решения уравнения типа x/a = b, с выводом значения x в ответе

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
cross666
22.02.2023 12:40

Датчик сөзінің мәнін, түс датчигінің түс, дыбыс, жарық-сәуле, температура, жылдамдықты өлшейтінін біледі; Датчиктердің қызметіне қарай 4 түрге бөлінетінін анықтайды.

Роботтың тірі организм принциптеріне негізделіп жасалатын автоматты құрылғы екенін біледі. .

Оқушылардың басым бөлігі: Түс датчигіндегі жарық деңгейін анықтайтын 8 түрлі түстің кодын біледі. Негізгі оқу-жаттығу роботының атын біледі;

Кейбір оқушылар: Түс датчигінің екі түрге электронды және механикалық болып бөлінетінін, оның үш режимін: Түс режимін, Шағылысқан жарық жарықтылығы, Сыртқы жарық жарықтылығы режимдерін біледі. LEGO MINDSTORMS EDUCATION EV3 программасын аша алады. Программа мәзірінен Нұсқаулықпен (Инструкция) танысып, роботтың құрастырылуын біледі.

0,0(0 оценок)
Ответ:
lada48
30.10.2021 15:55

1) Пароль в этом коде - "zn4n1j4". Заменить при необходимости.

var

 i: integer;

 s: string;


begin

 i := 1;

 while i <= 5 do

 begin

   readln(s);

   if s = 'zn4n1j4' then

   begin

     writeln('Вход в систему разрешен');

     exit;

   end;

   writeln('Неверный пароль.');

 end;

 writeln('Пароль не был угадан 5 раз.');

end.


2) Используем операцию x mod 10 для получения последней цифры числа и x div 10 для "отбрасывания" последней цифры числа.

var

 x, ans: integer;


begin

 read(x);

 ans := 0;

 while x <> 0 do

 begin

   ans := ans + (x mod 10);

   x := x div 10;

 end;

 writeln(ans);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота