Комментарий:
Да условие не до конца дописано, но с таким началом условия существует только одна задача:
определите значение переменной s после выполнения следующего фрагмента программы: s:= 0; for i:=1 to 9 do if A[i - 1] < A[i] then begin s := s + 1; t := A[i]; A[i] := A[i - 1]; A[i - 1] := t end;
Незачем считать, хотя и можно, проще просто запустить этот код:
var a: array [0..9] of integer = (1, 2, 4, 3, 5, 6, 8, 7, 3, 4); i, t, s: integer; begin s := 0; for i:=1 to 9 do if A[i - 1] < A[i] then begin s := s + 1; t := A[i]; A[i] := A[i - 1]; A[i - 1] := t end; write(s); end.Как мы видим, после выполнения данного в условии фрагмента переменная s будет равна 9.
Комментарий:
Да условие не до конца дописано, но с таким началом условия скорее всего это задача:
определите значение переменной s после выполнения следующего фрагмента программы: s:= 0; for i:=1 to 9 do if A[i - 1] < A[i] then begin s := s + 1; t := A[i]; A[i] := A[i - 1]; A[i - 1] := t end;
Незачем считать, хотя и можно, проще просто запустить этот код:
var a: array [0..9] of integer = (1, 2, 4, 3, 5, 6, 8, 7, 3, 4); i, t, s: integer; begin s := 0; for i:=1 to 9 do if A[i - 1] < A[i] then begin s := s + 1; t := A[i]; A[i] := A[i - 1]; A[i - 1] := t end; write(s); end.Как мы видим, после выполнения данного в условии фрагмента переменная s будет равна 9.