marinamoshonkina
20.11.2021 22:54

Составьте (Блок-Схему) к следующей задаче:

Напишите программу, которая возводит в степень заданное число.

( на картинке что-то тип того)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anechkasun1
06.02.2021 06:50
1. Размерностью, типом, статический/динамический, количеством измерений.
2. В классическом Паскале: var название массива:array[размерность/размерности] of тип (но на самом деле методов огромное количество)
3. Инициализация, установка размерности(динамический), ввод значений, манипуляции, освобождение памяти(динамический).
4. В классическом Паскале: имя массива[индекс элемента]:=значение (опять же, методов на самом деле много)
5.  В случае, если они присвоены посредством генератора псевдослучайных чисел.
6. 1. for i:=1 to размерность массива do
writeln(имя массива[i]);
2. for i:=1 to размерность массива do
write(имя массива[i]:4);
0,0(0 оценок)
Ответ:
akselroddasha
01.06.2021 11:05
1.var a,b,c:integer;
d,x1,x2:real;
begin;
readln(a);
readln(b);
readln(c);
d:=sqr(b)-4*a*c;
if d<0 then
   writeln('Нет корней')
   else
    if d=0 then
     begin;
      x1:=-b/(2*a);
      writeln(x1);
     end
      else
       begin;
        x1:=(-b+sqrt(d))/(2*a);
        x2:=(-b-sqrt(d))/(2*a);
        writeln(x1);
        writeln(x2);
       end;
end.
2)var x1,y1,x2,y2:integer;
r1,r2,rr:real;
begin;
readln(x1);
readln(y1);
readln(x2);
readln(y2);
r1:=sqrt(sqr(x1)+sqr(y1));
r2:=sqrt(sqr(x2)+sqr(y2));
if r1>r2 then
 begin;
  rr:=r1-r2;
  write('Расстояние от точки А до начала координат больше, чем расстояние от точки В до начала координат на ',rr,' единиц');
 end
  else
   if r1<r2 then
    begin;
     rr:=r2-r1; 
    write('Расстояние от точки B до начала координат больше, чем расстояние от точки A до начала координат на ',rr,' единиц');
    end
     else
      write('Точки A и B равноудалены от начала координат');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота