Darkhan06
08.10.2021 07:43

понять программу( ну то есть напишите комментарии к действиям)
заранее

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Clem404
14.07.2021 17:16

Чтобы наш снаряд (пуля, мяч или что-то еще) попало в цель, нужно чтобы высота подъема снаряда совпала с высотой, на которой расположена цель, и чтобы дальность полета совпала с заданным расстоянием. Иначе снаряд может улететь выше или ниже цели или не долетать.

Воспользуемся формулами по равнозамедленному движению.


program zadacha;

const

g=9.8;

var

h,L,a,V,S,h1:real;

begin

writeln('vvedite visotu i dalnost celi');

readln(h,L);

writeln('vvedite ugol, skorost snariada');

readln(a,V);

a:=a*pi/180;

h1:=int(( sqr(V)* sqr(sin(a))) / (2*g));

S:=int((sqr(V)*sin(2*a))/g);

if (S=L) and (h1=h) then writeln('popal') else writeln('ne popal');

end.


Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном р
Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном р
0,0(0 оценок)
Ответ:
ilyavarbanetsozotem
21.12.2020 15:10
Решение со смещением всех последующих элементов. 

program znanija;
const n = 21; // N + 1
var 
a:array[1..n] of integer;
m, i:integer;
begin

write('Введите позицию для вставки: ');
readln(m);

if (m<1) or (m>n-1) then
begin 
writeln('Недопустимое значение m'); 
exit;
end;

write('Массив до вставки: ');
for i := 1 to n-1 do
begin 
a[i] := random(100); 
write(a[i], ' '); 
end;

writeln();
for i := n - 1 downto m do // Смещение
a[i+1] := a[i]; 
  
a[m] := 10;  // Вставка

write('Массив после вставки: ');
for i := 1 to n do 
write(a[i], ' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота